Issues sending email
Incident Report for VitalSource
Resolved
This incident has been resolved.
Posted Oct 13, 2016 - 16:18 CDT
Investigating
We are currently experiencing issues sending email. We are working with to resolve.
Posted Oct 13, 2016 - 13:38 CDT
This incident affected: Bookshelf Online and Manage Platform.