Notes and Highlights is impaired
Incident Report for VitalSource
Resolved
This incident has been resolved.
Posted Sep 20, 2017 - 19:33 CDT
Monitoring
Services are recovered, we will be monitoring.
Posted Sep 20, 2017 - 19:15 CDT
Identified
We have identified the issue and are correcting.
Posted Sep 20, 2017 - 19:01 CDT