Engagement dashboards are offline
Incident Report for VitalSource
Resolved
This incident has been resolved.
Posted Sep 27, 2018 - 20:05 CDT
Investigating
We are currently investigating this issue.
Posted Sep 27, 2018 - 19:24 CDT
This incident affected: Analytics.