The VitalSource Store and Sampling platform is currently down. We are investigating.

Incident Report for VitalSource

Resolved

This incident has been resolved.
Posted Jun 26, 2026 - 06:11 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 26, 2026 - 05:59 EDT

Investigating

We are currently experiencing a service degradation. We are investigation.
Posted Jun 26, 2026 - 05:12 EDT
This incident affected: Store, Sampling and Ecommerce Platform.