Bookshelf Online Performance Issues

Incident Report for VitalSource

Resolved

This incident has been resolved.
Posted Jun 16, 2023 - 10:27 EDT

Investigating

We are investigating an issue impacting Bookshelf Online.
Posted Jun 16, 2023 - 10:16 EDT
This incident affected: Bookshelf Online.