Inability to access Bookshelf Explore

Incident Report for VitalSource

Resolved

This incident has been resolved.
Posted May 19, 2025 - 16:31 EDT

Monitoring

Bookshelf Explore has recovered. We are monitoring.
Posted May 19, 2025 - 16:21 EDT

Investigating

We are investigating an issue impacting Bookshelf Explore.
Posted May 19, 2025 - 16:10 EDT
This incident affected: VitalSource Explore.