Widespread system degradation
Incident Report for VitalSource
Postmortem

On March 18, 2022, from 9:59 AM till 10:03 AM Eastern time, VitalSource systems had a service degradation. This degradation came during routine non-downtime system maintenance to one of our application service clusters which we do several times a year. During this maintenance, application alerts went off indicating the issue and we quickly rolled back the changes. The problem appears to have originated with network errors communicating with one of our core subsystems during the maintenance. We are investigating the issue the issue and working with one of our service providers on the networking issue.

Posted Mar 18, 2022 - 13:11 CDT

Resolved
We are currently investigating this issue.
Posted Mar 18, 2022 - 09:00 CDT