Single Sign On (SSO) to bookshelf is failing in some scenarios

Incident Report for VitalSource

Postmortem

The root cause of this incident was related to the way we handle SSL certificates in our API redirect layer, which in turn caused a narrow set of SSOs into our Bookshelf product to fail.  This issue was exposed when our proxy networking layer did a routine cycle of a certificate. We have corrected this issue and audited our systems for any other scenarios where this might occur.

Posted Jan 06, 2022 - 15:55 EST

Resolved

This incident has been resolved.
Posted Jan 06, 2022 - 10:49 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 06, 2022 - 10:21 EST

Update

We are continuing to investigate this issue.
Posted Jan 06, 2022 - 09:22 EST

Update

We are continuing to investigate this issue.
Posted Jan 06, 2022 - 09:21 EST

Investigating

We are currently investigating this issue.
Posted Jan 06, 2022 - 09:21 EST
This incident affected: V3/V4 APIs and Bookshelf Online.