VST Store is offline
Incident Report for VitalSource
Resolved
VST Store is back, we will continue to monitor for any issues.
Posted 2 months ago. Oct 04, 2017 - 10:17 CDT
Investigating
We are currently investigating this issue.
Posted 2 months ago. Oct 04, 2017 - 10:04 CDT
This incident affected: Store, Sampling and Ecommerce Platform.