Google Cloud has identified the root cause of the incident that affected VitalSource services, along with other major parts of the internet. We are continuing to monitor the situation and will provide updates as needed.
We are continuing to monitor for any further issues.
Posted Jul 18, 2025 - 12:04 EDT
Monitoring
It appears Google Cloud has stablilized issues, we have recovered, we are monitoring for any lingering issues.
Posted Jul 18, 2025 - 12:02 EDT
Investigating
We are investigating this issue, early indicators are that this is related to broad Google Cloud Issues
Posted Jul 18, 2025 - 11:19 EDT
This incident affected: V3/V4 APIs, VitalSource Launch - LTI, LMS, SAML, Office365, OAuth2 and other integrations, Bookshelf Online, Manage Platform, Store, Sampling and Ecommerce Platform, VitalSource Explore, Analytics, Acrobatiq, Verba Collect, Verba Connect, Verba Compete, Verba Compare, and Akademos TextbookX.