Verba Collect performance issues

Incident Report for VitalSource

Resolved

This incident has been resolved.
Posted Sep 03, 2023 - 06:30 EDT

Monitoring

We have a fix in place, we are monitoring.
Posted Sep 03, 2023 - 06:04 EDT

Investigating

We are currently investigating an issue impacting Verba Collect.
Posted Sep 03, 2023 - 05:59 EDT
This incident affected: Verba Collect.