Store payment processing

Incident Report for VitalSource

Resolved

This incident has been resolved.
Posted Aug 30, 2020 - 11:09 EDT

Monitoring

We believe the issues have cleared.
Posted Aug 30, 2020 - 11:00 EDT

Update

Processing has improved. We believe that this is related to broad internet issues across the US.
Posted Aug 30, 2020 - 10:41 EDT

Identified

This may be related to broad CDN issues reported through out the US.
Posted Aug 30, 2020 - 10:12 EDT

Investigating

Our student store payment processor is having trouble processing credit card payments. We are working with them to solve the problem.
Posted Aug 30, 2020 - 09:28 EDT
This incident affected: Store, Sampling and Ecommerce Platform.