Service Disruption Impacting Bookshelf Online
Incident Report for VitalSource
Resolved
This incident has been resolved.
Posted Jan 17, 2025 - 08:40 EST
Monitoring
Bookshelf Online is operational, we are monitoring.
Posted Jan 17, 2025 - 08:18 EST
Investigating
We are investigating an issue impacting Bookshelf Online
Posted Jan 17, 2025 - 08:14 EST
This incident affected: Bookshelf Online.