Explore Performance Issues
Incident Report for VitalSource
Resolved
The performance issue affecting Explore has been resolved and all systems are now operating normally. We will continue to closely monitor Explore to ensure there are no further disruptions.
Posted Feb 08, 2023 - 21:48 CST
Update
We have implemented some mitigation which alleviates this issue for some users.
Posted Feb 08, 2023 - 14:04 CST
Update
We have identified the issue and are rolling out a solution.
Posted Feb 08, 2023 - 12:41 CST
Identified
We are addressing issues impacting Explore performance.
Posted Feb 08, 2023 - 08:58 CST
Investigating
We are addressing issues impacting Explore performance.
Posted Feb 08, 2023 - 08:58 CST
This incident affected: VitalSource Explore.